geen geluid via HDMI

Home Forums XBMC Live geen geluid via HDMI

Tagged: , , , ,

This topic contains 10 replies, has 3 voices, and was last updated by  adgr 3 years, 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #11259

    Raptor
    Member

    Hallo

    ik heb een
    Asrock ION 3D Intel Atom D525 Dual-Core, 2 GB, 320 GB
    en heb daar windows en xbmc op.
    xbmc draait op linux.
    ik wil mijn geluid via hdmi kabel naar mijn tv laten gaan, maar dit lukt me niet. Wel heb ik geluid in windows.

    Tot zover heb ik gedaan:geluidsinstellingen veranderd naar digitaal
    hdmi

    alles unmute in de mixer

    heel veel forums gelezen over dit probleem (waar het probleem ook verholpen word)
    Ik snap hier echter niks van
    ik krijg de indruk dat ik iets moet veranderen in linux iets met scripts of zo. Heb echter geen ervaring met linux en snap ook niks van script tutorials. Die mij gaan allemaal boven de pet.

    zou iemand hier bij kunnen helpen?

    #11260

    adgr
    Member

    Probeer eens wat je in dit topic ziet: http://forum.xbmcfreak.nl/topic/xbmc-geluid-op-ion2-platform

    Mocht dat niet werken, geef dan even de output van aplay -l op het asrock system onder unix.

    #11261

    Raptor
    Member

    ok de onderste instellingen heb ik gedaan maar dat bovenste is hocus pocus voor mij.
    Moet ik dat ergens letterlijk over typen?
    Moet ik het ergens plakken?
    Is het een soort van menu?

    Hoe kan ik de aplay -I zien?
    Heb net op wikipedia gezien dat unix een besturingsysteem is. Hoe kom ik daar en wat moet ik daar dan doen?

    #11262

    adgr
    Member

    Ok, je moet een terminalverbinding met het unix systeem maken.
    Daarvoor kun je bijvoorbeeld putty op je PC installeren en dan een telnet of ssh verbinding maken met het ip-adres van het unix/xbmc systeem.
    In de terminal die dan opent log je in met een username en password (standaard is dat xbmc en xbmc).
    Daarna tik je letterlijk het commando 1 in en drukt op return.
    Om het .asoundrc bestand aan te maken:
    Kopieer de hele inhoud op je windows systeem met CTRL+C en start daarna in de terminal een editor met:
    1
    Klik in de editor op de rechtermuisknop en de gehele tekst wordt in de editor geplakt.
    Daarna CTRL+X gevolgd door Y en ENTER
    De editor sluit dan af en als het goed is heb je nu een .asoundrc bestand met de juiste inhoud.
    Dit kun je controleren met het commando:
    1

    Succes!

    #11263

    Raptor
    Member

    Als je dat zo zegt lijkt het allemaal heel simpel.
    Ik heb putty gedownload en probeer verbinding te krijgen.
    Ik heb de asrock in xbmc staan.
    type in putty configuration het IP van mijn asrock (opgevraagt via windows internet “mijn IP” via de asrock, hoop dat dat de goede is).
    Dan druk ik op SSH en daarna op open.
    dan krijg ik de melding Network error:Connection refused
    Zal wel iets heel simpels zijn maar met helpsites kom ik er niet uit.

    #11264

    XtrordinarY
    Member

    Het is het handigst om je IP adres in XBMC af te lezen.

    Ik weet niet welke skin je gebruikt maar wanneer je naar de categorie Instellingen gaat kan je een submenu opvragen met o.a. systeeminformatie. Daar staat het IP adres van je Asrock.

    #11265

    Raptor
    Member

    ok ben in de arrock gekomen en heb de stappen gedaan.
    Welcome to Ubuntu!
    * Documentation: https://help.ubuntu.com/
    Last login: Tue Jul 26 16:21:06 2011 from 192.168.1.100
    raptor@XBMCLive:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC892 Digital [ALC892 Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    raptor@XBMCLive:~$ nano .asoundrc
    raptor@XBMCLive:~$ more .asoundrc
    raptor@XBMCLive:~$ .asoundrcpcm.!default {
    -bash: !default: event not found
    raptor@XBMCLive:~$ type hw
    -bash: type: hw: not found
    raptor@XBMCLive:~$ card 0
    -bash: card: command not found
    raptor@XBMCLive:~$ device 3
    -bash: device: command not found
    raptor@XBMCLive:~$ }
    -bash: syntax error near unexpected token `}’
    raptor@XBMCLive:~$
    raptor@XBMCLive:~$ ctl.!default {
    -bash: !default: event not found
    raptor@XBMCLive:~$ type hw
    -bash: type: hw: not found

    raptor@XBMCLive:~$
    Broadcast message from root@XBMCLive
    (unknown) at 16:32 …

    The system is going down for reboot NOW!

    Zoals je ziet heb ik hem opnieuw opgestart.
    Als ik nu een film opstart krijg ik in het midden van mijn scherm een kleine x verder reageert hij nergens meer op.
    Ik weet niet wat ik hier tegen moet doen.

    #11266

    adgr
    Member

    Je hebt om te beginnen de tekst die in het .asoundrc bestand moest komen als commando’s gegeven en daarom zie je steeds “not found”.
    Kijk eens in het bestand ~/.xbmc/temp/xbmc.log of je foutmeldingen ziet van rond de tijd dat je een film probeerde op te starten.

    #11267

    XtrordinarY
    Member

    Wat staat er in je .asoundrc?

    Nadat je nano .asoundrc intoetste kreeg je toen inderdaad een txt editor te zien?

    Is het compleet kopieren van de settings in de aangegeven thread van adgr gelukt? (kan je ook eventueel checken door weer nano .asoundrc te gebruiken)

    #11268

    Raptor
    Member

    ok ik heb de vorrige gedellete en deze ervoor in de plaats gezet:

    pcm.!default {
    type plug
    slave {
    pcm “both”
    }
    }

    pcm.both {
    type route
    slave {
    pcm multi
    channels 6
    }
    ttable.0.0 1.0
    ttable.1.1 1.0
    ttable.0.2 1.0
    ttable.1.3 1.0
    ttable.0.4 1.0
    ttable.1.5 1.0
    }

    pcm.multi {
    type multi
    slaves.a {
    pcm “tv”
    channels 2
    }
    slaves.b {
    pcm “receiver”
    channels 2
    }
    slaves.c {
    pcm “analog”
    channels 2
    }
    bindings.0.slave a
    bindings.0.channel 0
    bindings.1.slave a
    bindings.1.channel 1
    bindings.2.slave b
    bindings.2.channel 0
    bindings.3.slave b
    bindings.3.channel 1
    bindings.4.slave c
    bindings.4.channel 0
    bindings.5.slave c
    bindings.5.channel 1
    }

    pcm.tv {
    type hw
    card 0
    device 3
    channels 2
    }

    pcm.receiver {
    type hw
    card 0
    device 1
    channels 2
    }

    pcm.analog {
    type hw
    card 0
    device 0
    channels 2
    }

    daarna heb ik bij de instellingen
    geluisddoorgifte op digitaal
    de output device op nvidea hdmi
    geluidsuitgifte op nvdia hdmi

    en hij doet het eindelijk.

    Heel erg veel bedankt voor jullie hulp.

    #11269

    adgr
    Member

    Mooi dat het probleem is opgelost! Dan sluiten we dit topic nu maar.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘geen geluid via HDMI’ is closed to new replies.