XBMCFreak Livecd 9 series

April 21, 2010 by at 21:15 51 Comments

The new version took a while but I think it’s worth the wait. The XBMCFREAK Livecd is no longer Nvidia only and now should be a perfect match for AMD and Intel users. v14 replaces also all the generic test versions. Feel free to give comments.

- Amd, intel drivers added (no longer nvidia or nvidia ion only!)

- 2.6.30-20 kernel

- Sources.xml fixed (pictures is added as well).

- Corrected permissions on subfolders in XBMC homedir

- uPnp.xml added and PNP settings corrected.

- Menu sound is fixed when HDMI is used (/etc/asound.conf added)

- Index.html placed in root of webserver

- cache_dir sabnzbd is set to ramdisk

- changed sabnzbd log_level to 0 (only errors and warnings)

- moved xbmcresponseformat to cron.daily

- Xorg.conf “HWCursor” set to “False”. No longer a X on the screen after standby

- advancedsettings.xml should now be always working

Previous adjustments:

- Samba added with multiple shares to the livecd home directory

- Added Blu-Ray script and MakeMKV: http://www.xbmc.org/forum/showthread.php?t=67420

- USB0 added to /proc/acpi/wakeup, which will allow Microsoft USB compatible to wake up from stand-by

- uPNP, Remote webservices default on

- Alaska and Rapier skin added

- coretemp.ko and advancedsettings.xml compiled and added to show GPU and CPU temp on Nvidia ION platforms

- nvclock added

- lm-sensors added

- wget lynx lftp ftp zip added

- Permissions /usr/share/xbmc/web fixed, this should allow XBMC Music Streamer to stream

- wireless-tools wpasupplicant added

- python-software-properties added: http://www.xbmc.org/trac/ticket/8304

- Boot fix added: http://www.xbmc.org/trac/ticket/8579

- Proftpd added

- Launcher added: http://code.google.com/p/xbmc-launcher/downloads/list

- sabnzbdplus added, port 9090

- transmission added, port 9091

- mt-daapd added, port 9092

- apache2 added with redirects to sabnzb, transmission and mt-daapd

username and password combinations for sabnzb, transmission and mt-daapd: xbmc / xbmc

Download: http://xbmcfreak.binkey.nl/xbmcfreak911livev14.zip

Comments

  1. tom says:

    Great, thanks very much for this. Will download this now and test tomorrow.

  2. Perentaart says:

    Dat klinkt weer als een fijne update (zoals gewoonlijk)! Ik ga hem binnenkort zeker eens proberen.

  3. gavin says:

    how can i upgrade from v13 to v14

  4. miesjel says:

    @gavin
    it says in the statement that you cannot upgrade..

  5. Can not run with ATI HD 4xxx.

  6. bin says:

    Ok, updaten niet mogelijk dus. Dan de vraag: hoe kan ik deze versie installeren zonder al mijn instellingen en bestanden te verliezen?

  7. ronald says:

    hoi Bin,

    ligt een beetje aan je partities. Als je een losse “data” partitie gebruikt kan je er voor kiezen om deze niet te formateren tijdens de install. Als je de data ergens in je Home dir hebt staan kan je ze verplaatsen naar een soort “backup home”
    dus zeg /home/xbmc kopieer/verplaats je naar /home/xbmc-backup (commanda mv -R /home/xbmc /home/xbmc-backup.)

  8. bin says:

    @ronald
    Ik heb de partities zoals deze in v13 worden aangemaakt (2 geloof ik).
    Dan moet ik even kijken hoe dit is ingedeeld. Maar als ik het goed begrijp gaat het dus om alles wat op de Data partitie staat en/of alles wat in je home folder staat?

  9. ronald says:

    je kan per partitie aangeven of deze geformateerd moet worden.
    als je voor je partitie met als “doel” /home aangeeft dat deze niet geformateerd moet worden en je gebruikt dezelfde username (xbmc) dan wordt alles in de map /home/xbmc toch overschreven en ben je dus wel alles kwijt.

    je kan eventueel met een ubuntu live cd booten en met gParted je partities aanpassen van te voren (en dus een data partitie maken van je vrije ruimte)

  10. miesjel says:

    is de livecd eigenlijk ion-only of kan je ook met andere chipsets draaien??

  11. TomsterXP says:

    I can also not Start XBMC with Ati HD 4200 :-(

  12. DragonFly says:

    Scripts nog steeds niet vooruit te branden in deze release. Volgens dit http://forum.xbmc.org/showthread.php?t=61677 topic biedt kernel 2.6.32.7 wel soelaas. Helaas draait deze versie op 2.6.30-20.

    Aanpassingen in /etc/asound.conf werken misschien wel goed op een ION-systeem maar geven nu absolute stilte op een niet-ION systeem (via hdmi en default settings in geluidshardware)

  13. DragonFly says:

    Scripts zijn in deze release ook niet vooruit te branden. Volgens http://forum.xbmc.org/showthread.php?t=61677 moet het met kernel 2.6.32.7 wel werken. Deze xbcmfreak live draait echter op 2.6.30-20. Geen idee of dit nu een echt kernel probleem is of het een bug van XBMC is.

    Overigens resulteren de aanpassingen /etc/asound.conf open een niet ION systeem tot een compleet stille XBMC. Met instellingen van de laatste Generic v4 had ik met de default instellingen in XBMC gewoon geluid van het XBMC menu en films (via HDMI).

  14. Alberto says:

    Ik maak op dit moment gebruik van een van jou versies (XBMC live generic V3) en heb daar een probleem met webserver.

    Als ik bv poort 8082 invoer dan kan ik op dat moment inloggen via een browser of via mn Iphone.
    Maar zodra ik XBMC uit en aan zet dan werkt deze poort niet meer.
    Moet eerst een andere kiezen bv 8085.Zodra ik dit gedaan heb dan kan ik weer inloggen,TOT ik XBMC weer uit zet.
    Dan kan ik weer niet inloggen.Moet eerst wederom een andere poort instellen om weer toegang te krijgen.

    Vraag me af of dit probleem ook in deze versie zit (vraag me af of het iets te maken heeft met jou configuratie of dat het echt een XBMC probleem is)

  15. TomsterXP :

    I can also not Start XBMC with Ati HD 4200 :-(

    Amd is not working. AMD’s 10.x drivers won’t work on Karmic. You’ll have to wait till the next version.

  16. apathy says:

    Toeval is dat mijn xbmc gecrashed is, dus dan maar gelijk een nieuwe xbmc live.
    Na installeren wil ik mijn apple timecapsule benaderen, maar dit lukt me nu niet meer.

    De vorige keer was het toevoegen van de volgende regel in /etc/fstab voldoende. Nu niet meer. (nadat ik een directory /media/capsule chmod 777 heb aangemaakt):
    //10.0.1.1/Data/Media /media/capsule/ cifs user=timecapsule,password=****,rw,iocharset=utf8,noserverino,file_mode=0777,dir_mode=0777 0 0

    Weet iemand wat ik verkeerd doe?
    De error code die ik nu krijg is:
    cifs_mount failed w return code 6 “mount //10.0.1.1./Data is not a valid block device”

  17. apathy says:

    even een update, voor een eventuele volgende persoon die hier tegenaan loopt:

    oplossing:
    sudo apt-get install smbfs

    misschien kan dit mee in de volgende live cd?

  18. gavin says:

    how can i get the remote from asrock ion 330ht to work

  19. Daniel says:

    Werkt toevallig de Uitzendinggemist plugin ook beter met deze versie?

  20. daniel says:

    just wanted to let you know that I tried your live cd v14 on my computer which has an older nvidia agp card in it. lspci shows:
    nVidia Corporation NV17 [GeForce4 MX 420]
    and th auto graphics card detection didn’t work. I tried to go to tty7 or tty8 and I saw a whole mess of errors about NVRM trying to use driver version 180 blah and it said it couldn’t resulting in no X server running at all. I was put at tty1 to log in. i know how to fix if I wanted to do a permenant install as Iam familair with ubuntu since breezy badger but I merely wanted to try it as this machine runs lucid lynx and I am waiting for XBMC to hit the ppa’s or the regular repositories.

    Just thought I would leave this feedback.

    My graphics card is supported by the Nvidia 96 version driver if you were unaware of this fact. I tried you live cd on another computer which has a Nvidia 6200 and it worked flawless, GREAT WORK!

  21. Ramon de Klein says:
  22. apathy :

    even een update, voor een eventuele volgende persoon die hier tegenaan loopt:

    oplossing:
    sudo apt-get install smbfs

    misschien kan dit mee in de volgende live cd?

    Thx. Ik zal smbfs toevoegen aan de volgende versie.

  23. Alberto :

    Ik maak op dit moment gebruik van een van jou versies (XBMC live generic V3) en heb daar een probleem met webserver.

    Als ik bv poort 8082 invoer dan kan ik op dat moment inloggen via een browser of via mn Iphone.
    Maar zodra ik XBMC uit en aan zet dan werkt deze poort niet meer.
    Moet eerst een andere kiezen bv 8085.Zodra ik dit gedaan heb dan kan ik weer inloggen,TOT ik XBMC weer uit zet.
    Dan kan ik weer niet inloggen.Moet eerst wederom een andere poort instellen om weer toegang te krijgen.

    Vraag me af of dit probleem ook in deze versie zit (vraag me af of het iets te maken heeft met jou configuratie of dat het echt een XBMC probleem is)

    Ik heb dit verschijnsel ook wel eens gezien. Het heeft ermee te maken dat poort 8080 al bezet is. De guisettings.xml in v14 heb ik helemaal opnieuw aangemaakt. Waarschijnlijk zal het probleem dus wel opgelost zijn.

  24. Oizopower says:

    probeer onder Windows 7 eens de laatste nightly versie.
    http://mirrors.xbmc.org/nightlies/win32/

  25. Boes says:

    Sjit: Nieuwe versie op mijn asrock gezet en nu wordt mijn Externe USb HD niet meer gemount.. heeft iemand een tip hoe ik dit voor elkaar moet krijgen?

  26. Oizopower says:

    Oeps mijn bericht bovenstaand hoorde hier niet ;) , verwijder mijn bericht hierboven maar en deze ook. excuses

  27. Hallo

    Heb net v14 geinstalleerd op mijn Asrock 330HT. Waar ik in V13 nog geluid had over de analoge port heb ik dat nu niet meer.

    Terzijde, maar ook had ik moeite op de remote aan de praat te krijgen: wget was niet geinstalleerd maar apt-get install wget gaf error. Dat heb ik wel opeglost.

  28. spooner says:

    since installing this version I have no sound via HDMI, everything seems ok audio set to digital and hdmi..

    any suggestions?
    cheers

  29. adgr says:

    @spooner
    Try to use the .asouncrc file from this post http://www.xbmcfreak.nl/xbmc-live-triple-audio-output-nvidia-ion/
    It should solve your problem.

  30. n0ir says:

    The download-URl doesn´t work…:( Had to use http://xbmcfreak.binkey.nl/xbmcfreak911livev13.iso.

  31. spooner says:

    is there a way to change the text on the scrolling banner to english (the one with new release info etc etc) if not can I turn it off?

  32. adgr says:

    @spooner
    If you mean the RSS Feed that is scrolling at the bottom of the GUI, that is configured in the file /home/xbmc/.xbmc/userdata/RssFeeds.xml

  33. MIKEY says:

    Does anyone have a link to v14 that works?

  34. jammer says:

    seconded, giev link pleaz :)

  35. red says:

    link 1 and 2 don’t work

  36. corkie says:

    Ik probeer de laatste live-versies v13 en v14 te downloaden, maar de links werken niet. Is er nog een andere oplossing ?

  37. Vincent says:

    This link works, deze doet het: http://xbmcfreak.binkey.nl/xbmcfreak911livev14.zip

  38. scanboostar says:
  39. FROV says:

    Ik heb deze vandaag geïnstalleerd en het werkt uitstekend. Super.
    Hiervoor had ik die Ubuntu 10.04 gebaseerde geprobeerd, maar die liep niet.

    Wat ik na installatie van V14 nog moest doen was de remote aan de gang krijgen.
    Hiervoor heb ik de link van post 21 hierboven gebruikt (Ramon):
    ASRock leverde me deze file in de zipfile: lirc-nct677x-1.0.4-ubuntu9.10.deb.
    Deze geinstalleerd met ‘dpkg -i’ als root, selecteer Nuvotron en None, en klaar.
    Ik had geen last dat Nuvotron niet tevoorschijn kwam de eerste keer.

  40. Ronald says:

    Download link does not work?

  41. dto says:

    Works great, thanks! I’ve installed it to my new Revo and it works fine (avi, mkv wmv ect). The only thing that doesn’t work is M2TS. When I try to play m2ts file I got gray screen with some rubish. Anyone of you knows how to fix it?

  42. Tuur says:

    @Edo van Vliet

    Hi Edo
    Je schreef dat je het wget probleem hebt opgelost. Ik heb hetzelfde probleem dus ik ben benieuwd hoe je dat gedaan hebt. sudo apt-get install -y wget werkt niet.
    Ik heb wel een verhaal gezien, maar das erg omslachtig.
    http://forum.xbmcfreak.nl/topic/sudo-wget-command-not-found
    Had jij misschien een wat simpelere oplossing?

    PS ik heb een HDD install. Opstarten vanaf USB werkt niet, behalve in recovery mode. Daar kan ie wget wel vinden trouwens. Maar op de HDD install niet…

    Alvast bedankt.
    Groeten Tuur

  43. Galvatron says:

    Beste Mensen,

    Ik heb een ASrock ion 330HT en werkt perfect met de V14, heb wel apart de “remote” drivers geïnstalleerd.
    Echter wil de “mic-in” input en de “line-in” gebruiken, maar als ik er een microfoon op aansluit, dan hoor ik niets… binnen de optie alsamixer staat alles “00″ en dat is actief en volume op 100%
    Waar kan ik instellen dat de mic en of line-in actief worden??

    Greets,

  44. Just installed xbmcfreak v14 from usb key (using unetbootin) to my Acer AspireRevo R3610. HDMI audio did not work when running from the USB drive, but upon installation to my HDD, everything works perfectly. Even my card reader automatically mounts and is available as a source in my photos menu. Absolutely outstanding work. Wake from sleep via remote is awesome.

    Any idea why most video plugins and the itunes audio plugin don’t work and simply yield a “script error” message? Reply to nicholas.giardina@gmail.com

    Thanks again.

  45. Marcel says:

    I installed xbmcfreak v14 on ASRock ION 330HT-BD and … I am speachless.

    I worked with unix boxes years ago but now I am used to OSX. So I spent hours installing ubuntu, then XBMC just to recognize that playback is not smooth. I then switched to XBMC live with more success. After mastering HDMI audio it played back movies. But the xbmcfreak install was just plug and play, you should really place a link on ASRock pages as it is not easy to locate your site easily.

    Just for my understanding: Why does standard ubuntu + xbmc install not play back smoothly? What eats all the cpu? Is it not possible to xbmc priority for cpu ressources?

    Thanks and regards
    Marcel

  46. adgr says:

    @Marcel
    Did you check the video settings? Enable VDPAU and the CPU usage ate playback should go down, because the GPU then takes over the task of videodecoding.

  47. Ucmeflyby says:

    Playback on Revo 3610 is flawless. I have a problem with IP addressing and samba. I am seeing the message: * Reloading /etc/samba/smb/conf smbd only.

    How can I set the IP address as static? I have edited the /etc/network/interfaces file, but it causes connection to fail.

  48. Sethii says:

    Tryed to install it on Intel platform D510MO, no succes, hangs on on ‘nmdb’ i maked some corections by error and tryal in /etc/network/if-up.d/samba with moderate succes.. Only to find out that it doesent start X so XBMC cannot conect to it(trying to start nvidia graphic, says no monitor).. any help, corections wuld be apriciated!
    ## i tested also 10.08 build, no sound (ALSA not working corectly) tryed to compile it by my self by moderating scripts found on “http://ubuntuforums.org/showthread.php?t=1046137″ also witout succes. I thing i need help about this! :D Thanks!

  49. tonicek says:

    Great, but what about permanent Nuvoton chip support?
    It gets widely used as part of the ASRock ION330HT/BT (IR receiver hardware).
    There is no problem to add driver if system runs on HD, but this is a Live CD !!!

  50. tonicek says:

    @gavin
    You are not alone. Ask for Nuvoton chip support!!

Leave a Comment

*