XBMC 12.0 – Frodo final released

XBMC 12.0 final has been released. If you’re interested in this release grab a copy from: http://xbmc.org/download/

Here’s a short changelog:

  • HD audio support, including DTS-MA and Dolby True-HD, via the new XBMC AudioEngine (OSX/iOS not yet available)
  • Live TV and PVR support
  • h.264 10bit (aka Hi10P) video software decoding for anime
  • 64bit support in OSX to match the 64bit support in Linux
  • Improved image support, allowing the database to accomodate numerous additional image types and more interesting and complex skins
  • Support for the Raspberry PI
  • Initial support for the Android platform
  • Improved AirPlay support across all platforms, including AirPlay audio in XBMC for Windows to match the other platforms
  • Improved controller support in Windows and Linux
  • Advanced Filtering in the library
  • Video library tags to complement movie sets
  • Advanced UPnP sharing
  • Default video languages now match the language being used by XBMC
  • Translations now powered by Transifex

Comments

  1. Mike says:

    XBMC komt niet goed uit sluimerstand, beeld blijft gewoon gedimd,

  2. hansie says:

    stomme vraag misschien (ben er een tijdje uit geweest): kan ik eindelijk eens web browsen in xbmcubuntu? Hoe? En hoe kom ik vanuit xbmc in de Ubuntu desktop. Bedankt. Voor de rest ziet het er weer mooi uit in Frodo…

  3. Mitch says:

    Na het installeren van de beta’s versie waar ik vooral problemen ondervond met beeld en geluid toch maar eens de “XBMC 12.0 – Frodo Final” op mijn Asrock systeem geinstalleerd. Was zeer verrast dat nu alles perfect werkt.

    Ben weer een hele blije XBMC gebruiker , Top werk afgeleverd :-)

  4. apathy says:

    XBMC has no sound output after this update anymore, does anyone else have this too?
    I’ve tried all possibilities in the the sound options (ps. using optical sound output, not using hmdi) in the settings menu. Played with the settings in alsamixer, even reinstalled alsamixer. Still no sound output. Does anyone have an idea to solve this problem?

    I’m using the asrock ion 330 as hardware.

    Thanks.

  5. Cujo74 says:

    @Apathy, I experienced the same problem last week with this final release, have also an asrock 330 only using HDMI. It was driving me nuts and considered almost a complete new install.

    I played however with several audio settings, digital/analog/ hdmi etc and also de-installed and re-installed the add-on xbmc audio settings/mixer twice. After severall restarts and a second time toggling through the settings of this add-on, especially the second ice958 setting, I suddenly had al my sounds back. Strange, but it worked for me.

  6. joeks says:

    @apathy @Cujo74 Same here, had no sound after updating to Frodo final. But after fiddling with the two audio settings like Cujo74 mentions I got my sound back. I think the settings are renamed a bit since the last XBMC version because I couldn’t find the setting I used to have.

    But now I set it to Analog and IE958 (or something, sorry can’t check right now) and it works perfectly.
    No need for reinstall or anything.

  7. @joeks @apathy @Cujo74

    There will be a Frodo 12.1 within two weeks which solve many sound problems. Suspend and resume is a known one. The default audio settings as well. I’ll keep you posted and see if I can put up a beta image here.

  8. Wouter says:

    Werkt perfect! Alleen heb ik een probleempje dat hij niet doorlaad naar XBMC maar altijd opent in XBMCbuntu.
    Als ik daar inlog als root start hij xbmc, anders niet. Iemand een idee hoe ik dat kan verhelpen?

  9. Thomas says:

    Any chance of a 64 bit version anytime soon?

  10. joeks says:

    @Piethein Thanks for keeping us up to date! :)

  11. KEEN says:

    Receiver USB-Stick – Atom – ION – Combination for Frodo Live-TV

    Hi everyone,

    I know there a few people here that use the AsRock 330 or 330HT, since i bought mine due to the reviews here.

    Has someone tried to add a Receiver USB-Stick, to use the live TV of Frodo, with this system or a similar with an Atom-ION system? dose that work well?
    Would appreciate your comments.

    Thanks
    Keen

  12. Madcat says:

    Ik had ook na een keer opnieuw opstarten geen sound output devices,
    Dit verhelpt het probleem:

    Code:
    sudo cp /etc/init/lightdm.conf ~/lightdm.conf.bkp
    sudo nano /etc/init/lightdm.conf

    Find the line that contains:
    Code:
    exec lightdm -d

    Add this in the empty line right above it:
    Code:
    sleep 10

    Ff opslaan en als je weer inlogd bij xbmc werkt alles weer perfect

  13. Patrick says:

    @KEEN, I have a Asrock 3D 152D, cant even run the liveCD install frodo version,
    some how it stops during install, black screen. i guess there is a driver problem,
    or drivers missing.

    with the eden version i had no problem. trying to install now for a week. yesterday i tried with
    an openelec version, that seems to work. but i want to use the liveCD because i also install
    cups (airprint) and a webdav server..

  14. Mitch says:

    @ Patrick

    I am also running xbmcbuntu on a Asrock 3D 152D system without any probleem

    I Installed xbmcbuntu on usb stick with unetbootin

    You need for Asrock 3D 152D system the xbmcbuntu-12.00.Intel-NVIDIA.iso version

  15. Patrick says:

    Mitch,

    Hi Mich,

    Downloaded a newer verion of unetbootin, also downloaded again the iso you mentioned,
    And used a new usb stick

    Install hangs on “running post-installation trigger man-db”

  16. KEEN says:

    Patrick,

    Hi Patrick,

    I have a AsRock 100HT, and everything works fine. What you could do as a workaround, is to install the eden and dann update to Frodo over the Console.

    I’m realy curious if the Live works with a USB Receiver on your machine, since it is already “stronger” then mine.

    Cheers
    KEEN

  17. Patrick says:

    just an update, after trying to install frodo, i am back to eden, that install worked the second
    time, think i stay with eden, made today a backup because i saw theres frodo 12.2 but i got
    cold feet :)

  18. Patrick says:

    ziet er naar uit dat een aantal problemen werden veroorzaakt door errors met het RAM geheugen,
    ik heb nu nieuwe RAM en mijn systeem start weer op.

    ik heb nog steeds eden maar ik ga nu weer frodo 12.2 proberen

    wat ik wel vreemd vindt is dat linux niet boot met geheugen errors en xp wel?

    Patrick

  19. Jasper says:

    Hey,

    Mijn xbmc installatie blijft crashen bij opstarten.
    Heb meerdere malen geïnstalleerd op mijn Windows 8 prettige maar helaas krijg ik xbmc niet opgestart.

    Pc heeft voldoende ram, hdd en processor
    Tevens de Nvidia video kaart is slechts 2 jaar oud en nog prima geschikt om games te spelen.

    Dus heb echt geen idee waarom het niet wil werken.

Leave a Comment

*